现在位置: 首页 > 博客文章 > 电脑相关 > IT开发 > 开发语言 > 文章
+0°

你应该知道的PHP库

2024年04月21日 11:27:06 PHP  ⁄ 共 1470字 暂无评论 ⁄ 被围观 15次
下面是一些非常有用的PHP类库,相信一定可以为你的WEB开发提供更好和更为快速的方法。 图表库 下面的类库可以让你很简的创建复杂的图表和图片。当然,它们需要GD库的支持。 pChart – 一个可以创建统计图的库。 Libchart – 这也是一个简单的统计图库。 JpGraph – 一个面向对象的图片创建类。 Open Flash Chart – 这是一个基于Flash的统计图。 RSS 解析 解释RSS并是一件很单调的...
阅读全文
+0°

ImportError: Plotly express requires pandas to be installed.

2024年03月13日 18:08:10 Python  ⁄ 共 267字 暂无评论 ⁄ 被围观 71次
​在 Python3 环境下,使用 plotly 绘图时,发生了如下错误: ImportError: Plotly express requires pandas to be installed. 通过排查发现是使用了折行导入时报错的: import plotly.express as px 通过检索找到了解决办法,就是安装 pandas 即可,命令如下: python -m pip install pandas ​ 如果想了解这个问题更详细的说明,可以查看这里。 ​ 原文链接:https://blog.csdn.net/tzhuwb/artic...
阅读全文
+0°

38个基于Python的Web 开发框架

2023年10月22日 20:19:23 Python  ⁄ 共 5185字 暂无评论 ⁄ 被围观 680次
Web 开发是Python 应用中重要的一部分,下面总结了38个基于Python的Web 开发框架!其中有的历史悠久,有的发展迅速,还有的已经停止维护,大家可以根据情况参考学习。 1Django框架 官网:https://github.com/django/django.git Django是一个开放源代码的Web 应用框架,由纯Python写成,是目前 Python 语言中主流 de 三大Web框架之一(flask、django、tornado),是最容易上手的框架。 2 Flask框架 官网:http...
阅读全文
+0°

Linux 服务器中 PHP 版本从 5.x 升级到 7.x

2022年07月08日 12:01:09 PHP  ⁄ 共 2043字 暂无评论 ⁄ 被围观 1,905次
​如果把 Linux 服务器的 PHP 版本升级呢?比如目前版本是 PHP 5.6.40,升级到7.4 当前最最新版本 PHP 7.4.30。 查看当前 PHP 版本  php -v 卸载已安装的 PHP yum remove php-common 安装 EPEL 源 yum install epel-release 如果已安装过,则提示如下: 安装 remi 源 yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm 安装 yum-config-...
阅读全文
+0°

Use of undefined constant WP_ADMIN – assumed ‘WP_ADMIN‘

2022年07月08日 11:57:32 PHP  ⁄ 共 419字 暂无评论 ⁄ 被围观 1,733次
​如果 WordPress 网站运行的 PHP 版本 从 7.0 升级到 7.4,提示如下警告: Warning: Use of undefined constant WP_ADMIN - assumed 'WP_ADMIN' (this will throw an Error in a future version of PHP) in D:\xxx\wp-config.php on line 87 解决方法:按照提示,找到代码所在行,按提示修改代码即可。 if (WP_ADMIN === true) { define ('WPLANG', 'zh_CN'); } else { define ('WPLANG', 'zh_CN'); } 修改为: ...
阅读全文
+0°

Should be compatible with WP_Widget::widget($args, $instance)

2022年07月08日 11:53:35 PHP  ⁄ 共 398字 暂无评论 ⁄ 被围观 1,899次
​如果原有 WordPress 网站在 PHP 5.x 版本上运行正常,当把 PHP 版本升级到 7.x 时,可能会爆出很多警告提示,但是网站在警告的下方是可以展示并访问的。 警告信息: Warning: Declaration of news::widget($instance) should be compatible with WP_Widget::widget($args, $instance) in D:\xxx\wp-content\themes\xxx\includes\widget.php on line 13 解决方法:只需要按照警告提示,找到方法所在文件 D:\...
阅读全文
+0°

Premature end of script headers 或 End of script output before headers

2022年06月21日 16:55:00 Python  ⁄ 共 1000字 暂无评论 ⁄ 被围观 1,688次
​在测试 Python DB-API 使用流程脚本时,访问出现如下错误: ​ 查看 Apache 日志,错误信息如下: Premature end of script headers: dblink.py或者End of script output before headers: dblink.py dblink.py 脚本内容如下: #!/usr/bin/python # -*- coding: UTF-8 -*- import MySQLdb # 打开数据库连接 db = MySQLdb.connect("localhost", "数据库用户名", "数据库密码", "数据库", charset='utf8mb4') #...
阅读全文
+0°

/usr/bin/python: No module named pip

2022年06月21日 16:03:00 Python  ⁄ 共 822字 暂无评论 ⁄ 被围观 1,827次
​在安装 pip 工具时报错如下: /usr/bin/python: No module named pip 查找资料说先安装 ensurepip 模块,就可以恢复 pip: python -m ensurepip 可结果却又提示没有 ensurepip 模块: /usr/bin/python: No module named ensurepip 其实可以使用以下命令下载安装 pip 的脚本: curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py # 下载安装脚本 结果如下: # curl https://bootstrap.pypa....
阅读全文
+0°

推荐10 款好用的 Python IDE

2022年06月14日 00:53:35 Python  ⁄ 共 3207字 暂无评论 ⁄ 被围观 2,229次
​Python 非常易学,强大的编程语言。Python 包括高效高级的数据结构,提供简单且高效的面向对象编程。 Python 的学习过程少不了 IDE 或者代码编辑器,或者集成的开发编辑器(IDE)。这些 Python 开发工具帮助开发者加快使用 Python 开发的速度,提高效率。高效的代码编辑器或者 IDE 应该会提供插件,工具等能帮助开发者高效开发的特性。 这篇文章收集了一些对开发者非常有帮助的,好用的 10 款 Python IDEs。如果你有其...
阅读全文
+0°

ModuleNotFoundError: No module named ‘***‘

2020年08月30日 17:25:38 Python  ⁄ 共 371字 暂无评论 ⁄ 被围观 2,988次
在用 Python 编写程序后,如果在运行时报错如下,说明该模块还未安装,需要进行安装。 比如报错如下: ModuleNotFoundError: No module named 'reportlab' 其中,reportlab 是一个处理 PDF 和画图的 python 开源库,安装时通过 pip 工具直接安装即可,比如 Windows 系统下安装如图所示: 安装后,查看是否安装成功,命令如下: pip list  ​ 另外,一些安装和卸载的常见命令如下: 首次安...
阅读全文
+0°

python -m pip install –upgrade pip

2020年08月30日 17:22:36 Python  ⁄ 共 243字 暂无评论 ⁄ 被围观 2,674次
如果再用工具 pip 安装模块的过程中,出现如下提示: You are using pip version 10.0.1, however version 20.2.2 is available.You should consider upgrading via the 'python -m pip install --upgrade pip' command. 说明 pip 版本太低,直接按照提示的命令升级即可,如图: 原文链接:https://blog.csdn.net/tzhuwb/article/details/108308126
阅读全文
+0°

Python 格言(The Zen of Python)

2020年08月30日 00:21:55 Python  ⁄ 共 991字 暂无评论 ⁄ 被围观 2,665次
Python 的设计哲学是“优雅”、“明确”、“简单”。因此,Perl 语言中“总是有多种方法来做同一件事”的理念在 Python 开发者中通常是难以忍受的。Python 开发者的哲学是“用一种方法,最好是只有一种方法来做一件事”。在设计 Python 语言时,如果面临多种选择,Python 开发者一般会拒绝花俏的语法,而选择明确的没有或者很少有歧义的语法。由于这种设计观念的差异,Python 源代码通常被认为比 Perl 具备更好的可读性,并且能够支...
阅读全文
+1°

你用的 JDK 版本居然还是1.5!

2018年06月30日 05:52:18 Java  ⁄ 共 526字 评论数 1 ⁄ 被围观 2,655次
项目开发中, 有时候真是让人无可奈何! 辛苦开发的项目, 在服务器上部署时, 居然跑不起来,查其原因, 居然是 JDK 版本太低! java -version 一下, 居然是 1.5。。。 是 1.6 。。。 在这个计算机技术以指数级增长的时代, 不要求咱的服务器中软件环境时时保持最新, 但最起码应该在一定时间内更新一次吧。 jdk 1.5 版本,怎么让目前开发的程序能跑起来, 而且官网版本已经...
阅读全文
+0°

Iterator在迭代中删除元素抛异常

2016年12月14日 16:11:21 Java  ⁄ 共 3033字 暂无评论 ⁄ 被围观 2,607次
Iterator 仅用于遍历集合,本身并不提供像集合类那样装对象的能力。Iterator 是个借口,如果需要创建其对象,必须有一个被迭代的集合,没有集合的 Iterator 没有存在的价值。 所以说,Iterator 必须依附于 Collection 对象,有一个 Iterator 对象,肯定就有一个与之关联的 Collection 对象。文章《Java遍历HashSet为什么输出是有序的》一文中开始有个例子,可以看到在迭代 HashSet 的过程中对迭代遍历进行赋值,但最后输出时发...
阅读全文
+0°

Java遍历HashSet为什么输出是有序的

2016年12月14日 12:34:32 Java  ⁄ 共 5399字 暂无评论 ⁄ 被围观 2,807次
今天运行《疯狂Java讲义》中 8.2 中的 IteratorTest.java 时,不管运行多少次,结果输出都是一致的,如下所示: Code   ViewPrint package com.menglanglang.java.collection; import java.util.*; /**  * Description:  * <br/>网站: <a href="http://www.crazyit.org">疯狂Java联盟</a>  * <br/>Copyright (C), 2001-2016, Yeeku.H.Lee  * <br/>This program is protected by copyright l...
阅读全文